Uploaded image for project: 'EJBCA'
  1. EJBCA
  2. ECA-1563

EJBCA does not deploy on JBoss EAP 5.0.0.GA

    Details

    • Type: Task
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: EJBCA 3.10.1
    • Component/s: None
    • Labels:
      None

      Description

      Note: ONly related to JBoss EAP, which is RedHats supported commercial version.

      There seems to be a bug in EAP 5.0.0 that makes dependencies between a war and ejb's in ear files fail when using ejb2.x.
      https://jira.jboss.org/jira/browse/JBPAPP-2419
      See also thread:
      http://community.jboss.org/thread/146509

      It will not be possible to solve this in EJBCA since we can not guess a random uid for the dependency. The only way is to remove the dependency.

      Keep this issue until there is a new JBoss EAP to test with, hopefully it will be fixed in JBoss EAP 5.0.1, as it does work in JBoss 5.1.0.

      Until then we have to recommend JBoss EAP 4.3.0 for people using the EAP versions.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              johan Johan Eklund
              Reporter:
              tomas Tomas Gustavsson
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0 minutes
                  0m
                  Logged:
                  Time Spent - 2 hours
                  2h