Uploaded image for project: 'EJBCA'
  1. EJBCA
  2. ECA-3992

Remove critical BC warnings in order to upgrade BouncyCastle to version 1.51

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: EJBCA 6.2.6
    • Fix Version/s: EJBCA 6.2.7
    • Component/s: None
    • Labels:
      None

      Description

      Due to a bug encountered by a customer in versions <=1.50, we should upgrade BouncyCastle to the latest version, 1.51

      BC 1.51 has a suspected bug that causes errors in deserialization of PublicKey, so until this issue is resolved/confirmed to be on my end we'll hold off on the upgrade.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              mikek Mike Agrenius Kushner
              Reporter:
              mikek Mike Agrenius Kushner
              Verified by:
              Johan Eklund
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: