Uploaded image for project: 'EJBCA'
  1. EJBCA
  2. ECA-6222

Public key exponent min value can be larger than max value for the RSA Key Validator.

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Trivial
    • Resolution: Fixed
    • Affects Version/s: EJBCA 6.9.1
    • Fix Version/s: EJBCA 6.11.0
    • Component/s: None
    • Labels:
      None
    • Issue discovered during:
      Review
    • Sprint:
      EJBCA Sprint 4

      Description

      Public key exponent min value can be larger than max value for the RSA Key Validator. It shouldn't be possible to save a faulty configuration.

      Remember:

      • This should be guarded against both in the GUI and in the backend
      • Gui error output should be user friendly and localized

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Hodell Anton Hodell
              Reporter:
              mikek Mike Agrenius Kushner
              Verified by:
              Mike Agrenius Kushner, Ulf Undmark
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - 4 hours Original Estimate - 4 hours
                  4h
                  Remaining:
                  Time Spent - 1 hour, 44 minutes Remaining Estimate - 4 hours
                  4h
                  Logged:
                  Time Spent - 1 hour, 44 minutes Remaining Estimate - 4 hours
                  1h 44m