Uploaded image for project: 'EJBCA'
  1. EJBCA
  2. ECA-6358

RA End Entity Search stops working until page reload if session is lost

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: EJBCA 6.10.1
    • Component/s: RA UI
    • Labels:

      Description

      If the session is lost, then searching or filtering in the RA Search End Entity page stops working. The list will reload, but with the same results and an NPE is logged in the server log.

      To reproduce:
      1. Open the "End Entity Search" page.
      2. Search for something.
      3. Restart the appserver.
      4. Change the search --> The results should be updated, but aren't.

        Attachments

          Activity

            People

            Assignee:
            samuel Samuel Lidén Borell
            Reporter:
            samuel Samuel Lidén Borell
            Verified by:
            Mike Agrenius Kushner
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Time Tracking

                Estimated:
                Original Estimate - 2 hours
                2h
                Remaining:
                Time Spent - 1 hour, 30 minutes Remaining Estimate - 30 minutes
                30m
                Logged:
                Time Spent - 1 hour, 30 minutes Remaining Estimate - 30 minutes
                1h 30m