- Better code, with less message keys, and more readable message keys
- It's better for: Localizators, Java developers
- Refactoring the message keys of actions to one unique word for each action, for Certificate Profile, Crypto Token, SCEP, etc.
- Rename VIEWCERTIFICATEPROFILE to VIEW
- Rename EDITCERTIFICATEPROFILE to EDIT
- Rename DELETECERTIFICATEPROFILE to DELETE
Note/History: before the button labels were wider, e.g. "Edit Certificate Profile", but with the new tables and its column 'Actions', all buttons are narrow (with a short word 'Edit'). So, it's better to have one unique word for one unique action verb.
Remarks about verbs:
- Common for objects: View, Edit, Delete, Remove, Rename, Clone
- Common for forms: Import, Export, Save, Cancel, Reset
- Specific: Set, Test, Apply, Search, Refresh, Deactivate, Activate, Reactivate, Generate, Revoke, etc.
This issue only process items from the first list, i.e. Common for objects one.