Uploaded image for project: 'EJBCA'
  1. EJBCA
  2. ECA-7479

Prevent compiling with Java 11, as long as it doesn't work

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: EJBCA 6.15.1
    • Component/s: None
    • Labels:
      None
    • Issue discovered during:
      Community
    • Sprint:
      EJBCA Team Alice - 2018 w45

      Description

      Java 11 is the default java in OS:es like Ubuntu 18.04. This causes support issues since neither EJBCA not WildFly (<14) runs on Java 11 yet.

      Until we can run on Java 11 reliable, we should add a warning if Java 11 is used.

      ant have variables so we can detect java version and error out if java is > 8 (and we haven't added an "javaversion.ignore" variable.

      We have had several support issues on this topic already.

        Attachments

          Activity

            People

            • Assignee:
              tomas Tomas Gustavsson
              Reporter:
              tomas Tomas Gustavsson
              Verified by:
              Tarmo Raudsep
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Time Tracking

                Estimated:
                Original Estimate - 1 hour
                1h
                Remaining:
                Time Spent - 30 minutes Remaining Estimate - 30 minutes
                30m
                Logged:
                Time Spent - 30 minutes Remaining Estimate - 30 minutes
                30m