Uploaded image for project: 'EJBCA'
  1. EJBCA
  2. ECA-7535

Regression: Upgrade of customcertextensions.properties fails

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: EJBCA 6.15.0
    • Fix Version/s: EJBCA 7.0.0, EJBCA 6.15.2
    • Component/s: None
    • Labels:
      None
    • Issue discovered during:
      Jenkins
    • Sprint:
      EJBCA Team Bob - 2018 w45

      Description

      The upgrade code for 6.15.0 expects the property "required" to exist in certextensions.properties and throws CertificateExtensionConfigurationException on startup if not (due to an NPE).

      This property is new in 6.15.0 and has never existed in the certextensions.properties (this file was used up to 6.4.0). So the upgrade code should not try to read it.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              samuel Samuel Lidén Borell
              Reporter:
              samuel Samuel Lidén Borell
              Verified by:
              Mike Agrenius Kushner
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - 20 minutes Original Estimate - 20 minutes
                  20m
                  Remaining:
                  Remaining Estimate - 0 minutes
                  0m
                  Logged:
                  Time Spent - 2 hours
                  2h