Uploaded image for project: 'EJBCA'
  1. EJBCA
  2. ECA-7603

Use explicit ECC parameters is always false after a Statedump import

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Won't Do
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
    • Issue discovered during:
      Customer

      Description

      "Use explicit ECC parameters" is ignored when a Statedump is imported. The correct value is in the Statedump, but something goes wrong during the import and the "Use explicit ECC parameters" is always disabled even if enabled in the Statedump.

      This is not a cache issue. JBoss was restarted and "Use explicit ECC parameters" was still disabled.

      I suspect something is going wrong in StatedumpSessionBean.importCryptoTokens.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned
              Reporter:
              bastianf Bastian Fredriksson
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - 2 hours
                  2h
                  Remaining:
                  Time Spent - 30 minutes Remaining Estimate - 1 hour, 30 minutes
                  1h 30m
                  Logged:
                  Time Spent - 30 minutes Remaining Estimate - 1 hour, 30 minutes
                  30m