Uploaded image for project: 'EJBCA'
  1. EJBCA
  2. ECA-8280

Seconds in certificate's "valid from" and "valid to" fields (EJBCA API)

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: EJBCA 7.2.0
    • Component/s: None
    • Environment:
      Database: Oracle 18c
      EJBCA 6.15.0
      WildFly 10
      Oracle JDBC 6
    • Sprint:
      EJBCA Team Alice - 2019 w24

      Description

      Hello,

       

      There is one problem with issuing certificates via API on customer's productive system.

      When certificates are issuing via GUI the time in "Valid From" and "Valid To" fields (seconds) are correct.

      The problem appears when certificates are issued via API. Then seconds are always zeroes ":00". It causes big problems for the customer.

      We've tried it with 6.15 enterprise, 6.2 and 6.3 version of EJBCA. Unfortunately in all of these cases the behaviour is the same (wrong).

       

      Thanks for your help in advance!

      Best regards,

      Mateusz

       

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              hsunmark Henrik Sunmark
              Reporter:
              mateusz.kowalski@esysco.pl Mateusz Kowalski
              Verified by:
              Henrik Sunmark, Samuel Lidén Borell
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: