Uploaded image for project: 'EJBCA'
  1. EJBCA
  2. ECA-9440

Regression: CA UI links do not work with a HTTP proxy running on a different port/hostname/scheme

    Details

      Description

      When using a HTTP proxy (rather than an AJP proxy), AdminWeb images/links include the internal appserver port/hostname/scheme, rather than the one that the proxy listens on. The exact behavior seems to vary depending on the configuration.

      Such configurations might be used when the proxy server provides the authentication, for example when using web.reqauth=false or when using the upcoming OAuth Bearer token authentication.

      We should fix this, preferably by using relative URLs in the AdminWeb.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              samuel Samuel Lidén Borell
              Reporter:
              samuel Samuel Lidén Borell
              Verified by:
              Ulf Undmark
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - 2 days Original Estimate - 2 days
                  2d
                  Remaining:
                  Remaining Estimate - 0 minutes
                  0m
                  Logged:
                  Time Spent - 2 days, 4 hours
                  2d 4h